Wow?


Na ich weiß ja nicht. Arne schwärmt ja seit sei­nem Erwerb der Win­dows Vis­ta Busi­ness Edi­ti­on in einer Tour von dem neu­en Streich von Micro­soft. Zeit wur­de es ja, ist es doch mitt­ler­wei­le über fünf Jah­re her, dass Micro­soft die Welt mit Win­dows XP geseg­net hat. Seit Ende Dezem­ber flie­gen nun auch die ISOs der Busi­ness Edi­ti­on im MSDN mei­ner Fach­hoch­schu­le rum, lei­der nur in eng­li­scher Spra­che, was auch der Grund war, wie­so ich bis jetzt mit der Instal­la­ti­on gewar­tet habe. Nun, die deut­sche Fas­sung ist noch immer nicht ver­füg­bar, aber wie sich her­aus­ge­stellt hat, funk­tio­niert mein Key auch mit der deut­schen Retail-Fas­sung ein­wand­frei, Akti­vie­rung wur­de auch erfolg­reich abge­schlos­sen. Scheint also ganz so, als ob unse­re FH die deut­sche Fas­sung mitt­ler­wei­le rum­flie­gen hat, das Rechen­zen­trum nur zu faul war, die­se auch in unser MSDN-AA einzupflegen ;-)

Bill Gates ein­zi­ger Aus­spruch zum neu­en Betriebs­sys­tem aus dem eige­nen Hau­se war bei sei­ner Prä­sen­ta­ti­on in New York “Wow.”. Viel mehr fiel mir beim ers­ten Blick auf das neue Sys­tem auch nicht ein, degra­diert es mein Sys­tem doch zu einer Krü­cke. Weder die Gra­fik­ef­fek­te noch die neu­en Funk­tio­nen haben mich bis­her vom Hocker geris­sen, was viel­leicht aber auch dar­an liegt, dass ich all das schon von Mac OS X ken­ne… scnr

Die neu­en Anwen­dun­gen wie Win­dows Mail, die Win­dows-Foto­ga­le­rie, der Win­dows-Kalen­der und Win­dows-Kon­tak­te machen auf den ers­ten Blick schon mal einen ganz brauch­ba­ren Ein­druck, wenn sie auch unschwer erkenn­bar an die Pen­dants unter OS X ange­lehnt aus­se­hen. Etwas gewöh­nungs­be­dürf­tig ist am Anfang die Tat­sa­che, dass Win­dows Vis­ta bei sicher­heits- und sys­tem­re­le­van­ten Ope­ra­tio­nen, wie bspw. Soft­ware­instal­la­tio­nen, einen Abfra­ge-Bild­schirm ein­blen­det, der fragt, ob das auch tat­säch­lich gewünscht ist. Gut so, unter OS X ver­schär­fe ich das Gan­ze ja noch mit einer Pass­wort­ab­fra­ge… bei Instal­la­ti­ons­or­gi­en aber eher ner­vig, hier wäre eine gene­rel­le Frei­ga­be für eini­ge Minu­ten wün­schens­wert. Ver­mut­lich lies­se sich soet­was aber wie­der zu Unguns­ten des Ver­fah­rens aus­nut­zen, von daher will ich mal nicht meckern.

In Sachen Bedie­nung müs­sen sich Win­dows-Benut­zer etwas umstel­len, eini­ge Ein­stel­lungs­mög­lich­kei­ten lie­gen nun kom­plett anders­wo, die Sys­tem­steue­rung beinhal­tet selbst in der Klas­si­schen Ansicht nicht die Ele­men­te, die man dort erwar­tet. Aber man ist ja noch jung. Sich umzu­ge­wöh­nen, soll­te eigent­lich kein Pro­blem darstellen.

Zurück aber zum eigent­li­chen Kri­tik­punkt: die Per­for­mance. Wie bereits in eini­gen ande­ren Arti­keln erwähnt, setzt sich mein der­zei­ti­ger Win­dows-Rech­ner aus einem Ath­lon XP 2.800+ Bar­ton mit 2 GB RAM, einem Asus A7N8X‑X (nVi­dia nForce2), einer 160 GB Sea­gate SATA-Fest­plat­te mit 7.200 rpm und 8 MB Cache sowie einer Gain­ward GeFor­ce 7800 GS 512 MB (umge­la­bel­ter GeFor­ce 7900 GT) zusam­men. Ansich also ein gar nicht so schwa­ches Sys­tem, vor allem für ein Betriebs­sys­tem soll­te das mei­ner Mei­nung nach voll­kom­men genü­gen, oder? Aber Pus­te­ku­chen, das Sys­tem ist lahm, also wirk­lich lahm. Von einem flüs­si­gen Arbei­ten kann ich hier nicht reden. Ich wer­de heu­te noch mal den aktu­el­len Trei­ber von der nVi­dia-Home­page her­un­ter­la­den und instal­lie­ren, die deut­sche Sei­te scheint aber gera­de tot zu sein. Auf der .com habe ich einen Vis­ta-Trei­ber für mei­ne Gra­fik­kar­te, nicht aber für mei­nen Chip­satz gefun­den. Hof­fent­lich steigt die Dar­stel­lungs­ge­schwin­dig­keit mas­siv an, wenn der neue Trei­ber instal­liert ist. Für mei­nen D‑Link-WLAN-Stick habe ich glück­li­cher­wei­se sofort einen Vis­ta-Trei­ber gefun­den, der am 31.01.07 ver­öf­fent­licht wur­de. Also so ziem­lich genau einen Tag vor mei­nem Expe­ri­ment. Die Trei­ber­su­che für mei­ne Sound­kar­te (X‑Fi Extre­me Music) gestal­te­te sich schon etwas schwe­rer: das Auto­Up­date von Crea­ti­ve Labs brach immer wie­der mit der Mel­dung ab, dass der Ser­ver über­las­tet sei. In den Down­loads habe ich kei­nen spe­zi­fi­schen Trei­ber für die Kar­te gefun­den, der Fatal1­ty-Trei­ber funk­tio­niert aber auch. Scha­de nur, dass er aus­schließ­lich auf Eng­lisch und in einer Beta-Ver­si­on vor­liegt. Na gut, der Fair­ness hal­ber muss man ja auch dazu sagen, dass das fina­le Pro­dukt erst seit zwei Tagen offi­zi­ell auf dem Markt erhält­lich ist. Dass Trei­ber trotz­dem erst so zeit­nah ver­öf­fent­licht wer­den, fin­de ich hin­ge­gen schon komisch, wis­sen doch auch Hard­ware­her­stel­ler, dass MSDN-Abon­nen­ten deut­lich frü­her an das fina­le Pro­dukt kom­men. Außer­dem arbei­tet das Power Manage­ment nicht kor­rekt, beim Auf­wa­chen aus dem Stand­by funk­tio­nie­ren weder mei­ne USB-Tas­ta­tur noch ‑Maus, da hilft nur ein Reset. Auch äußerst unschön…

Was jetzt genau so lah­mar­schig ist? Eigent­lich alles. Der Sys­tem­start dau­ert län­ger als bei XP, obwohl es eigent­lich hieß, wenigs­tens mei­ne ich mich dar­an zu erin­nern, dass die­ser schnel­ler als bei XP von­stat­ten gehen sol­le. Wenn die Sicher­heits­ab­fra­ge ein­ge­blen­det wird, steht für etwa eine hal­be Sekun­de das gan­ze Sys­tem. Hier wird näm­lich nicht nur ein Fens­ter ein­ge­blen­det, son­dern, zuguns­ten einer höhe­ren Auf­merk­sam­keit des Benut­zers ver­mut­lich, der gesam­te Hin­ter­grund ver­dun­kelt. Und das scheint mei­ner klei­nen Gra­fik­kar­te zu viel abzu­ver­lan­gen… ;-) Zwei Auf­ga­ben par­al­lel ablau­fen zu las­sen, was unter XP gar kein Pro­blem war, über­for­dert mein Sys­tem unter Vis­ta. Die “respon­si­ve­ness” neigt sich gen extrem ner­vig. Hof­fent­lich wird da noch nachgebessert…

Posi­tiv fin­de ich, dass ab sofort anschei­nend wirk­lich alle Ein­stel­lun­gen im Ord­ner “Users” auf der Sys­tem­par­ti­ti­on befin­den. Dort fin­de ich nicht nur mei­ne eige­nen Daten son­dern auch die Ein­stel­lun­gen der von mir instal­lier­ten Anwen­dun­gen. So soll es sein. Unter Mac OS X und Linux schon seit Ewig­kei­ten gang und gäbe. Schön, dass M$ auch hier end­lich mal den Kopie­rer ange­wor­fen hat. Apro­pos Ord­ner: die Ord­ner, die auf der Ober­flä­che Benut­zer und Pro­gram­me hei­ßen, hei­ßen unter der Hau­be Users und Pro­gram Files. Kenn ich irgend­wie auch von OS X… na ja, so lan­ge die Sachen wirk­lich gut kopiert wer­den, kann mich das ja nur freu­en. Lei­der fällt mir hier auch gleich wie­der ein nega­ti­ver Punkt ein: wie­so um alles in der Welt kann ich die­sen däm­li­chen Ord­ner Users nicht ein­fach, wie unter XP mit dem Ord­ner Eige­ne Datei­en, auf eine ande­re Par­ti­ti­on ver­schie­ben? Mei­ne Nut­zer­da­ten hab ich immer ganz gern auf einer ande­ren Par­ti­ti­on als der Sys­tem­par­ti­ti­on. Bei Vis­ta müss­te ich aber hier doch tat­säch­lich sämt­li­che vom Sys­tem erstell­ten Nutz­da­ten-Ord­ner wie Bil­der, Musik, etc. ein­zeln in ein ande­res Ver­zeich­nis ver­schie­ben. Da es sich um Sys­tem­ord­ner han­delt, wür­de ein Auf­ruf eines die­ser Ord­ner über das, im Übri­gen recht ansehn­li­che und gut auf­ge­bau­te, Start­me­nü eine Feh­ler­mel­dung pro­du­zie­ren, da der Ord­ner nicht an der erwar­te­ten Stel­le liegt. Ich müss­te dem Sys­tem also irgend­wie mit­tei­len, dass mei­ne Nut­zer­da­ten nun bspw. auf Par­ti­ti­on D und nicht mehr C lie­gen. Nach ein wenig Recher­che habe ich auch einen Weg gefun­den, der (angeb­lich) funk­tio­nie­ren soll:

———-

- Als Admi­nis­tra­tor ein­log­gen
- Aus­füh­ren -> rege­dit -> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList]
- Unter­schlüs­sel für den eige­nen Benut­zer suchen
- Den Ein­trag Pro­fi­leIm­age­Path auf den gewünsch­ten Pfad ändern
- Im Explo­rer die Datei­en von C:\Users in den gewünsch­ten Ord­ner verschieben

———-

Im ach-so-ein­fa­chen und intui­tiv zu bedie­nen­den Vis­ta muss ich also an der Regis­try (wie­so exis­tiert die immer noch? *heul*) rum­schrau­ben, um mei­ne Nut­zer­da­ten zu ver­schie­ben? Um etwas zu tun, was ansatz­wei­se unter XP schon mit weni­gen Maus­klicks funk­tio­niert hat?

Gut, eigent­lich nut­ze ich die­se Kis­te ja wirk­lich aus­schließ­lich zum Spie­len und wenn mal eine Anwen­dung nicht für mei­nen Mac exis­tiert. Schö­ne Über­lei­tung, just in die­sem Augen­blick instal­lie­re ich näm­lich mal eini­ge Spie­le auf dem Sys­tem. Im Ein­zel­nen wären das Battle­field 2 inkl. aller Add-Ons, Battle­field 2142, Dark Mes­siah, Advan­ced War­figh­ter und Splin­ter Cell 4. Sobald die drauf sind, wer­de ich mir die aktu­ells­ten Updates holen und alle fünf Titel mal antes­ten. Bin echt mal gespannt, ob ich wenigs­tens in etwa die gewohn­te Per­for­mance erhal­te oder nicht. Auf­ge­fal­len ist mir aber, dass trotz einer in kei­ner Hin­sicht ver­än­der­ten Kon­fi­gu­ra­ti­on die Instal­la­ti­on der Spie­le deut­lich län­ger dau­ert. Wor­an liegt das? Er tut doch in etwa das sel­be wie unter XP auch, oder etwa nicht?

Nun ja, ich hal­te auch auf dem Lau­fen­den. Viel­leicht ändert sich ja doch noch etwas zum posi­ti­ven. Ich ver­su­che dem Sys­tem so unvor­ein­ge­nom­men gegen­über zu ste­hen, wie nur irgend mög­lich. Möch­te ja nicht, dass mir wie­der “Fan­boy­is­mus” vor­ge­wor­fen wird ;-)

Wer Tipps für mich hat, die Per­for­mance von ganz-schön-mau auf flüs­sig zu stei­gern, ohne die neue Aero-Ober­flä­che zu kil­len, möge mich infor­mie­ren. Dan­ke schon mal!

[UPDATE]

Mein Rech­ner hat im Übri­gen eine Basis­be­wer­tung von 3,5, was durch den rela­tiv lah­men Pro­zes­sor zustan­de kommt. Der Spei­cher hat 4,1, auch ein Fla­schen­hals, wohin­ge­gen Gra­fik­kar­te (bei­de Teil­be­wer­tun­gen) und Fest­plat­te mit einem Wert von 5,9 respek­ti­ve 5,3 daher kom­men. Laut Online­hil­fe sagt eine Basis­be­wer­tung von 3 aber aus, dass Aero pro­blem­frei lau­fen soll. Sehe ich anders… :/

[UPDATE 2]

Habe mitt­ler­wei­le alle Pro­gram­me, die ich gele­gent­lich unter Win­dows benut­ze, wenn ich mal nicht mit der Kis­te zocke, instal­liert. Und alle lau­fen, wenn auch deut­lich lang­sa­mer als unter XP. Nur der PDFCreator will nicht, was wohl am zu instal­lie­ren­den Trei­ber liegt, der scheint noch nicht Vis­ta-kom­pa­ti­bel zu sein.

Was nun aber wirk­lich nervt: stän­di­ger Fest­plat­ten­zu­griff. Ich ver­mu­te ja mal, dass das ins Sys­tem inte­grier­te Desk­top-Search die neu hin­zu­ge­kom­me­nen Daten indi­ziert. Aber wie­so stoppt die­ser Vor­gang nicht, wenn ich was am Rech­ner mache? Wer­de wohl noch ein oder zwei Stünd­chen war­ten müs­sen, bis der Indi­zie­rungs­vor­gang abge­schlos­sen ist…

[UPDATE 3]

Nächs­te Stu­fe des Expe­ri­ments: Instal­la­ti­on von Win­dows Vis­ta Busi­ness auf dem Rech­ner mei­ner Freun­din. Da sie eben­falls Stu­den­tin ist, habe ich die Tat­sa­che genutzt, dass sie genau wie ich einen kos­ten­lo­sen Key bekom­men hat und Vis­ta auch auf ihrem Rech­ner instal­liert. Ihr Rech­ner setzt sich aus einem Pen­ti­um IV 2,66 GHz mit 1,5 GB RAM, einen Asus P4PE‑X, einer 160 GB Sea­gate PATA 7.200 rpm, einer 160 GB Sam­sung PATA 7.200 rpm mit jeweils 8 MB Cache und einer GeFor­ce 7600GT 256 MB von Xpert­vi­si­on sowie einer Crea­ti­ve Sound Blas­ter Audi­gy 2ZS zusam­men. Das Ergeb­nis: ähn­lich kata­stro­phal wie auf mei­nem Rech­ner. Die Arbeit gestal­tet sich äußerst zäh­flüs­sig, Gra­fik- und Sound­kar­ten­trei­ber arbei­ten insta­bil bzw. sind im Fal­le des Sound­kar­ten­trei­bers eben­falls nur in einer Beta ver­füg­bar (die Audi­gy 2ZS ist schon eini­ge Zeit auf dem Markt, trotz­dem bringt Vis­ta kei­nen Trei­ber mit). Das Stand­by-Spiel­chen habe ich gar nicht erst aus­pro­biert, da auch ihre Tas­ta­tur und Maus über die USB-Schnitt­stel­le mit dem Rech­ner ver­bun­den sind. Wie Arne mir mit­teil­te, muss man sich laut einem Arti­kel auf WinFuture.de mit dem Micro­soft-Sup­port in Ver­bin­dung set­zen, um den ent­spre­chen­den Patch zu beziehen.

Da die Gute sowohl in ihrer Frei­zeit als auch für ihr Stu­di­um Anwen­dun­gen wie Pho­to­shop ein­set­zen muss, wer­de ich Vis­ta wohl wie­der von der Fest­plat­te ent­fer­nen müs­sen. Allein das Betriebs­sys­tem mit Viren­scan­ner belegt laut der bei­geleg­ten Mini­an­wen­dung für die Side­bar bereits 48 % des vor­han­de­nen Arbeits­spei­chers. Wo soll Pho­to­shop noch Platz finden?

Sie spielt auch gele­gent­lich, der­zeit befin­den sich Sac­red Gold Edi­ti­on, Spell­for­ce Pla­ti­num Edi­ti­on und Spell­for­ce 2 auf ihrem Rech­ner. Sac­red star­tet, läuft aber deut­lich lang­sa­mer als noch unter XP. Spell­for­ce Pla­ti­num Edi­ti­on ist gar nicht zum Star­ten zu bewe­gen und Spell­for­ce 2 star­tet nur, wenn man es über das Kon­text­me­nü expli­zit als Admi­nis­tra­tor star­tet. Viel wei­ter geht’s aber auch nicht, ein Direc­tX-Feh­ler been­det das Ver­gnü­gen, bevor es begon­nen hat. Schnell (*hüs­tel*) Direc­tX 9 nach­in­stal­liert, schon star­tet das Spiel. Aber auch hier ist die Per­for­mance deut­lich nied­ri­ger als unter XP.

Ihr Rech­ner hat eine Basis­be­wer­tung von 3,8 bekom­men (wie­der ist die CPU der Fla­schen­hals), der Spei­cher erhielt 4,3, Fest­plat­te und Gra­fik­kar­te lagen jeweils zwi­schen 5,3 und 5,8.

Fazit: Expe­ri­ment wird abge­bro­chen. Ich wer­de im Ver­lau­fe des Tages wie­der Win­dows XP auf dem Rech­ner auf­spie­len müs­sen. Viel Zeit ver­geu­det für nichts.

Fazit 2: Auch auf mei­nem Rech­ner wird Vis­ta nur noch eini­ge Tage zwecks nähe­rem anschau­en instal­liert blei­ben. Sobald ich wie­der spie­len möch­te, muss Vis­ta wei­chen. Battle­field 2142 bspw. läuft mit exakt den glei­chen Ein­stel­lun­gen rund 40 % lang­sa­mer als unter XP. Beim Start von Splin­ter Cell 4, Ghost Recon und Dark Mes­siah ruckelt allein schon das Ubi­Soft-Video. Ghost Recon läuft unspiel­bar trä­ge, auf mehr als 10 fps kom­me ich nicht, wo vor­her bei­na­he 30 (!) drin gewe­sen sind.

Vor­erst end­gül­ti­ges Fazit: Den ges­tern per ICQ erhal­te­nen Aus­spruch “Future needs power” (Zitat von Bill Gates?) scheint Micro­soft etwas zu wört­lich genom­men zu haben. Soll ich mir ernst­haft für den Betrieb von Vis­ta Busi­ness (!), was ja nun für den geschäft­li­chen Ein­satz geschaf­fen wur­de, einen Quad­core-Pro­zes­sor nebst 4 GB RAM und einer GeFor­ce 8xxx holen? Das ist kein Busi­ness-Rech­ner, son­dern eine Spie­le-Maschi­ne. Ich sehe vor­aus, dass auf die­se Aus­sa­ge Reak­tio­nen kom­men wer­den wie “Aero kann man ja deak­ti­vie­ren” oder ähn­li­ches. Mei­ne Ant­wort wür­de dann in etwa lau­ten, dass man das sicher­lich kann, aber ich wür­de doch schon gern alles nut­zen, was ein Betriebs­sys­tem leis­ten kann, wenn ich dafür so viel Geld aus­ge­ben muss. Na gut, ich muss nicht, aber Otto-Nor­mal-Mensch muss. Wäre ja qua­si so, als wenn ich mir einen Por­sche kau­fe und dann die gan­ze Zeit nur 100 km/h fah­ren kann, weil ansons­ten viel­leicht irgend­was lei­den muss. Dass das “Wow jetzt kommt” kann ich nicht bestä­ti­gen, sor­ry Bil­ly… In einem hal­ben Jahr gebe ich dei­nem tol­len Betriebs­sys­tem viel­leicht erneut eine Chan­ce, vor­her wird das ver­mut­lich nix… Wie ich gera­de ent­deckt habe, hat­te die c’t vor kur­zem einen Arti­kel zu genau die­sem The­ma. Den wer­de ich mir im Ver­lau­fe des Tages mal zu Gemü­te führen.

Posi­tiv zu erwäh­nen bleibt im End­ef­fekt nur das Aus­se­hen der neu­en GUI, wobei ich die­se per­sön­lich etwas über­la­den fin­de, die neu­en Sicher­heits­me­cha­nis­men und die neu­en bei­geleg­ten Anwen­dun­gen. Aber all das wiegt den schier unglaub­li­chen Res­sour­cen­hun­ger des neu­en Betriebs­sys­tems nicht auf. Ein Betriebs­sys­tem benö­ti­ge ich zum Arbei­ten und evtl. zum Spie­len. Für genau das lässt Vis­ta aber nicht mehr vie­le Res­sour­cen übrig, wenn man einen nur mit­tel­mä­ßig aus­ge­stat­te­ten Rech­ner wie mei­ne Freun­din und ich hat. Vor­erst also: Adieu, Vis­ta… (Has­ta la Vis­ta wäre hier natür­lich lus­ti­ger gewe­sen, passt nur vom Sinn her lei­der nicht ;-))


Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.